TEAM-ADA Archives

Team Ada: Ada Programming Language Advocacy

TEAM-ADA@LISTSERV.ACM.ORG

Options: Use Classic View

Use Proportional Font
Show HTML Part by Default
Condense Mail Headers

Topic: [<< First] [< Prev] [Next >] [Last >>]

Print Reply
Sender: "Team Ada: Ada Advocacy Issues (83 & 95)" <[log in to unmask]>
Date: Tue, 5 Oct 0100 23:13:29 GMT
Parts/Attachments: text/plain (42 lines)
>The professors there are very concerned because their
>students are performing much more poorly than they did with Pascal as an
>intro language.

My immediate reaction is best described as "Well Duh".
What the heck can you expect?

I've seen this phenomenon before, only using Ada and Java.

Basically, an Organisation of my acquaintance used to teach Ada in 1st year,
with all classes in Database design etc etc in suceeding years in C or C++,
because that's all the lecturers knew.

The students didn't have enough time to both learn C/C++ and also learn the
complex concepts (cryptology, etc) in 2nd and 3rd years.

Now you might think, as I thought, that the obvious solution was to stop teaching
complex concepts in C, and do it in Ada. But that would have meant most of the
Academic staff actually having to learn and become proficient in a new language.


So now they teach Java in first year, so the students don't have to struggle
quite so much in 2nd year etc with C syntax. And the professors find that they
can compile their old C programs using a Java compiler quite easily. The OO
gurus who used C++ (Ada's not OO! they cried, not that they'd ever written a
single line in it..) also find Java superior to C++ in many ways.

Meanwhile the students learn marketable skills: Java, Java and Java, hacking
and code-cutting instead of this Ada software engineering stuff. Everyone's
happy.

Except for people like myself, who see standards slipping, and the quality of
software engineering fast eroding... fortunately Java, in conjunction with graphical
development freeware like BlueJ, is actually better in some ways than the old
command-line-only GNAT v 3 or less that was previously used. (Why didn't they
upgrade to v10 or above despite repeated requests? Too busy installing the latest
LINT or whatever I guess.)

Sorry to appear all bitter and twisted, but "fighting the good fight" for three
consecutive years and getting thoroughly hosed will do that to you. Mainly because
I haven't given up, I've seen a better way of doing things.

ATOM RSS1 RSS2